Stepperdriver probleem

Discussie in 'CNC' gestart door benovitch, 12 sep 2017.

  1. benovitch

    benovitch

    Lid geworden:
    20 apr 2005
    Berichten:
    408
    Locatie:
    België/Nieuwkerken Waas
    Enkele weken geleden ben ik begonnen aan de bouw van een aangepaste KIM Pro freesmachine. Ik heb deze aangepast omdat ze anders te groot uitviel voor de ruimte waarin ze moest komen. Origineel staan de motoren aan de buitenzijde van de machine waardoor deze +/- 15-20cm groter wordt. Ik heb deze helemaal hertekend en dan de motoren aan de binnenkant van de frames gemonteerd. De cnc wordt aangestuurd door Estlcam met Nema 23 motoren en DM542t stepperdrivers van https://www.omc-stepperonline.com/ een 36V voeding.

    Afgelopen weekend was ik wat aan het testen met de machine om alles te leren kennen en merkte dat mijn Z-as steeds dieper in het materiaal ging frezen. Eerst dacht ik dat het werkblad niet vlak was maar toen ik zag dat ze bijna 5mm in het werkblad freesde kon het dat al zeker niet zijn.

    Ben dan beginnen meten met de schuifmaat en vergelijken met de software. Ik kwam toen tot de conclusie dat bij één omwenteling van de motor de as 5mm naar beneden gaat. Echter op de pc staat 6.25mm aangegeven. Dit zowel in de opwaartse beweging als in de neerwaartse.

    Ben dan gaan vergelijken met de X en Y as deze werkte perfect.

    Ik heb toen de driver van de Z-as naar de Y-as gewisseld om te zien of het in de software zat of in de sturing.

    Nu komt het rare, toen ik de Y-s op de pc 5mm verplaatste was dit effectief ook 5mm op de machine. Ook de Z-as met de andere driver werkte perfect. Ik verstond mij hier niet aan en dacht ok we testen dan maar weer eens.

    Tijdens het frezen merkte ik al snel op dat ook de Y-as verliep tijdens het uitfrezen.

    Heb toen maar geconcludeerd dat de driver stuk is en een nieuwe besteld terwijl ik wacht op de nieuwe die ik in garantie krijg.

    De nieuwe zou er morgen zijn en hopelijk kan ik dan verder zonder problemen.


    Wat mij het meeste stoorde is dat op de Z-as ik 6mm aflees op het scherm en 5mm op de machine en op de Y-as deze gelijk is.

    Iemand dezelfde problemen gehad?

    20170813_104344.jpg 20170813_113214.jpg 20170813_141036.jpg 20170813_142654.jpg 20170826_162846.jpg IMG_20170909_160746.jpg
     
  2. Midas

    Midas

    Lid geworden:
    9 jun 2012
    Berichten:
    18
    Locatie:
    Assen
    Heb je de dipswitches op alle drivers gelijk ingesteld?
     
  3. benovitch

    benovitch

    Lid geworden:
    20 apr 2005
    Berichten:
    408
    Locatie:
    België/Nieuwkerken Waas
    Ondertussen is het probleem opgelost. Het was wel degelijk de driver zelf die kuren had. Er zit een nieuwe in en nu werkt alles naar behoren.
     
  4. Tronald Dump

    Tronald Dump Verbannen

    Lid geworden:
    5 sep 2017
    Berichten:
    177
    Locatie:
    Reutum
    Leuke machine! Wat frees je hier mee?
     
  5. benovitch

    benovitch

    Lid geworden:
    20 apr 2005
    Berichten:
    408
    Locatie:
    België/Nieuwkerken Waas
    Vooral hout en gfk/cfk normaal. Mss ook als het gaat alu. Maar eerst dienen de flanken van de Y-as vervangen te worden door HPL.
     
  6. frans32

    frans32

    Lid geworden:
    16 apr 2010
    Berichten:
    118
    @benovitch,

    Waaorm niet gelijk uit aluminium maken dan?
    is er gelijk ook de mogelijkheid om misschien de voorkant en achterkant op het frame ook te voorzien van aluminium. maakt het geheel alleen maar sterker.
    ook met het oog op de toekomst om aluminium te gaan frezen.

    mooi concept overigens qua machine.
     
  7. benovitch

    benovitch

    Lid geworden:
    20 apr 2005
    Berichten:
    408
    Locatie:
    België/Nieuwkerken Waas
    Binnen in het onderste frame zit al een hele constructie van I-nut profielen. Dat gaat stijf genoeg zijn.
     

Deel Deze Pagina